SR ENGINE PACK

Post Reply
User avatar
Nightkid
Gangster
Posts: 218
Joined: 24 Sep 2019 13:43
Location: Saitama, Japan

15 Oct 2019 10:48

most recent update of the SR...

Author: BRCrew, Driftmonkey

Hi all, this is on what I work since many month now, an updated version of the very good looking Andy's SR20 with lot of more customization and variant, you have now :

- SR16
- SR18
- SR20
- SR22
- SR23

you can now build FWD SR, you have to rotate the engine yourself for now but i will fix that in a future update

this is a first release so im still working on it and more part will come again in future, its not perfect but i hope you will like it

Credits :

- Andy Oliver for the photorealistic base mod
- Toretto cause I grouped some of his setup in this mod
- DowDow for a drag setup also grouped in this pack
- Ah Uea ( OwnzzGames ) for the Nismo intercooler
- Nightkid for amazing screenshot in the spoiler

and thanks to my friend Rambo for help on 3D stuff and EliasFD3S for his texture skill :)

if I forgot someone let me know :)

ImageImageImageImageImageImageImageImageImageImageImage




02/10/19 : Updated the link with more new part ( Filters, new cover, new turbo, water pump, NOS rail etc )
Download :
Hidden Content
This board requires you to be registered and logged-in to view hidden content.
Last edited by Nightkid on 10 Nov 2019 19:45, edited 1 time in total.
Image

User avatar
SimplifyHerb
Gangster
Posts: 395
Joined: 25 Sep 2019 10:48
Location: Osaka, Japan

15 Oct 2019 17:42

Best engine mod, ever I seen!
Previous username; Buzzsaw.
My Roleplay Link: viewtopic.php?f=55&t=13457
RP location; Osaka, Japan

RP's My vehicle owned:
► Show Spoiler
RP's Angel's (My GF) vehicle owned:
► Show Spoiler
RP's My previous owned vehicle:
► Show Spoiler

User avatar
Doge
Associate
Posts: 32
Joined: 11 Oct 2019 16:51
Location: Slovenia

15 Oct 2019 21:04

Looks amazing, good job!
Image
"...he's a good boy, just as you'd expect from a shibe" -Bigg Boss93

theredfox
Associate
Posts: 1
Joined: 03 Oct 2019 17:28

16 Oct 2019 19:25

Sorry for being a total noob but where do i install the addons/sounds for the engine :P

User avatar
Polderlife
Associate
Posts: 19
Joined: 29 Sep 2019 15:15
Location: Netherlands

16 Oct 2019 19:51

theredfox wrote:
16 Oct 2019 19:25
Sorry for being a total noob but where do i install the addons/sounds for the engine :P
Drag sounds into the main SLRR folder. Latest engine update, just drag and drop into the engines folder and replace files.
P O L D E R L I F E

O G Hotbois

BMW Gang

bitelaserkhalif
Associate
Posts: 4
Joined: 09 Oct 2019 11:40

18 Oct 2019 11:20

That's a nice motor over here

PS: great job of making it compatible with all car without sleditor

Edit: Apparently, i discovered several bug (underpowered engine), I made a java fix for it:
Click
Just unpack to game directory and replace the file it asked
bitelaserkhalif back here again!
(thankfully this site didn't nuked by hdd crash, a.k.a archive is made!)
(if you are trying to access old downloads, replace vstanced.com to archive.vstanced.com)

Driftmonkey
Associate
Posts: 4
Joined: 08 Nov 2019 08:53

08 Nov 2019 08:55

Underpowered engine ? in wich game/physic do you try it ?

User avatar
SimplifyHerb
Gangster
Posts: 395
Joined: 25 Sep 2019 10:48
Location: Osaka, Japan

08 Nov 2019 10:00

Why Tomei turbo only fitted stock intercooler but stock turbo can fitted stock or aftermarket intercooler? I'm sure that mistaken, @Nightkid .
Edit; I mean, @Driftmonkey
Last edited by SimplifyHerb on 08 Nov 2019 11:44, edited 1 time in total.
Previous username; Buzzsaw.
My Roleplay Link: viewtopic.php?f=55&t=13457
RP location; Osaka, Japan

RP's My vehicle owned:
► Show Spoiler
RP's Angel's (My GF) vehicle owned:
► Show Spoiler
RP's My previous owned vehicle:
► Show Spoiler

User avatar
Nightkid
Gangster
Posts: 218
Joined: 24 Sep 2019 13:43
Location: Saitama, Japan

08 Nov 2019 10:56

Buzzsaw wrote:
08 Nov 2019 10:00
Why Tomei turbo only fitted stock intercooler but stock turbo can fitted stock or aftermarket intercooler? I'm sure that mistaken, @Nightkid .
Don´t ask me , ask
Driftmonkey wrote:
08 Nov 2019 08:55
Underpowered engine ? in wich game/physic do you try it ?
him lmao
Image

User avatar
SimplifyHerb
Gangster
Posts: 395
Joined: 25 Sep 2019 10:48
Location: Osaka, Japan

08 Nov 2019 11:43

Nightkid wrote:
08 Nov 2019 10:56
Buzzsaw wrote:
08 Nov 2019 10:00
Why Tomei turbo only fitted stock intercooler but stock turbo can fitted stock or aftermarket intercooler? I'm sure that mistaken, @Nightkid .
Don´t ask me , ask
Driftmonkey wrote:
08 Nov 2019 08:55
Underpowered engine ? in wich game/physic do you try it ?
him lmao
Oh sorry. I will. :lol:
Previous username; Buzzsaw.
My Roleplay Link: viewtopic.php?f=55&t=13457
RP location; Osaka, Japan

RP's My vehicle owned:
► Show Spoiler
RP's Angel's (My GF) vehicle owned:
► Show Spoiler
RP's My previous owned vehicle:
► Show Spoiler

Driftmonkey
Associate
Posts: 4
Joined: 08 Nov 2019 08:53

08 Nov 2019 17:06

@Buzzsaw my bad i forgot to put the slot for the other intercooler on the Tomei turbo, i fix that and send it

Edit : okay its done i fixed the slot on the Tomei turbo and i added the little spec fix from @bitelaserkhalif i just updated the main download so redownload the engine to have the fix

User avatar
DudeWithSpells
Associate
Posts: 1
Joined: 06 Oct 2019 21:09

10 Nov 2019 17:47

Is it just me, or does the engine not start up and work for other people? It'll almost get to the RPM where it'll start, but it always stops short. heavily modded engines do this, engines with two or three custom parts will do this, and stock engines will do this. I have the script fix from bitelaserkhalif, but the same thing happens. How do I fix this?

User avatar
Polderlife
Associate
Posts: 19
Joined: 29 Sep 2019 15:15
Location: Netherlands

10 Nov 2019 19:23

DudeWithSpells wrote:
10 Nov 2019 17:47
Is it just me, or does the engine not start up and work for other people? It'll almost get to the RPM where it'll start, but it always stops short. heavily modded engines do this, engines with two or three custom parts will do this, and stock engines will do this. I have the script fix from bitelaserkhalif, but the same thing happens. How do I fix this?
It's a little funky for me too, I find that going through every gear then starting usually works a treat. Sometimes it just wont start with N1 Cams or what not. Trial and Error until another fix comes forward
P O L D E R L I F E

O G Hotbois

BMW Gang

Driftmonkey
Associate
Posts: 4
Joined: 08 Nov 2019 08:53

11 Nov 2019 09:42

just try to start it and then when around 400 or 500 rpm release the throttle and it start, or try to adjust the RPM idle value

Yellodegu
Associate
Posts: 2
Joined: 03 Oct 2019 01:57

25 Dec 2019 02:40

where did you get the nismo sentra mod?

User avatar
BigSmoke
Gangster
Posts: 437
Joined: 03 Oct 2019 11:19
Location: Indonesia

25 Dec 2019 08:21

Yellodegu wrote:
25 Dec 2019 02:40
where did you get the nismo sentra mod?
Say hi to the Sentra here.
Still following the damn train since 1992

Image


Visit my RP HERE!
Or read it from the very beginning HERE!

jiz0.
Associate
Posts: 1
Joined: 29 Dec 2019 00:27

29 Dec 2019 12:30

It crashes in multiple sections of the catalog for me without error log.
Under Cylinder Heads andCharging system.
Running BB93s Stage1

User avatar
Nightkid
Gangster
Posts: 218
Joined: 24 Sep 2019 13:43
Location: Saitama, Japan

29 Dec 2019 17:48

jiz0. wrote:
29 Dec 2019 12:30
It crashes in multiple sections of the catalog for me without error log.
Under Cylinder Heads andCharging system.
Running BB93s Stage1
@Driftmonkey
Image

User avatar
SimplifyHerb
Gangster
Posts: 395
Joined: 25 Sep 2019 10:48
Location: Osaka, Japan

29 Dec 2019 18:53

@Driftmonkey also fix weird stall/slow starting
Previous username; Buzzsaw.
My Roleplay Link: viewtopic.php?f=55&t=13457
RP location; Osaka, Japan

RP's My vehicle owned:
► Show Spoiler
RP's Angel's (My GF) vehicle owned:
► Show Spoiler
RP's My previous owned vehicle:
► Show Spoiler

スカイラインRacer
Associate
Posts: 3
Joined: 24 Oct 2019 03:10

03 Jan 2020 06:38

Does it work with 2.3.1?

Driftmonkey
Associate
Posts: 4
Joined: 08 Nov 2019 08:53

29 Jan 2020 09:26

@jiz0. wich version of SLRR do you have ?

@SimplifyHerb i will the day i will be back on this thing, i moved on another game project

@スカイラインRacer nope

User avatar
ijdevil
Associate
Posts: 42
Joined: 15 Jan 2020 13:41
Location: North Carolina

23 Feb 2020 15:23

Anyone know what the correct loading order or texture is supposed to be for the Twin turbo intercooler
sl_shot102.jpg
sl_shot102.jpg (77.73 KiB) Viewed 2757 times

kimkgb
Associate
Posts: 2
Joined: 17 Mar 2020 17:29

18 Mar 2020 17:26

Probably the best engine pack so far, love it!
But somehow i dont get the engine sound to work. :?

placed it in: Enginesounds-Engine-AddOns-

is this right? thanks for answer :D

Ulopong22
Associate
Posts: 1
Joined: 17 Dec 2019 10:37

19 Mar 2020 01:32

the engine sound is not working :?

User avatar
BigSmoke
Gangster
Posts: 437
Joined: 03 Oct 2019 11:19
Location: Indonesia

19 Mar 2020 09:29

kimkgb wrote:
18 Mar 2020 17:26
Probably the best engine pack so far, love it!
But somehow i dont get the engine sound to work. :?

placed it in: Enginesounds-Engine-AddOns-

is this right? thanks for answer :D
Not sure if this is the right answer, but try placing the AddOns folder in the main game folder instead of going deep into the engine sounds folder
Still following the damn train since 1992

Image


Visit my RP HERE!
Or read it from the very beginning HERE!

User avatar
SimplifyHerb
Gangster
Posts: 395
Joined: 25 Sep 2019 10:48
Location: Osaka, Japan

19 Mar 2020 09:36

BigSmoke wrote:
19 Mar 2020 09:29
kimkgb wrote:
18 Mar 2020 17:26
Probably the best engine pack so far, love it!
But somehow i dont get the engine sound to work. :?

placed it in: Enginesounds-Engine-AddOns-

is this right? thanks for answer :D
Not sure if this is the right answer, but try placing the AddOns folder in the main game folder instead of going deep into the engine sounds folder
That what I did it age ago, it use be work.
Previous username; Buzzsaw.
My Roleplay Link: viewtopic.php?f=55&t=13457
RP location; Osaka, Japan

RP's My vehicle owned:
► Show Spoiler
RP's Angel's (My GF) vehicle owned:
► Show Spoiler
RP's My previous owned vehicle:
► Show Spoiler

User avatar
Nightkid
Gangster
Posts: 218
Joined: 24 Sep 2019 13:43
Location: Saitama, Japan

19 Mar 2020 10:10

kimkgb wrote:
18 Mar 2020 17:26
Probably the best engine pack so far, love it!
But somehow i dont get the engine sound to work. :?

placed it in: Enginesounds-Engine-AddOns-

is this right? thanks for answer :D
ok here´s your answer
Copy Addon and parts folder into your main slrr directory . That way the addon folder will end up in the main slrr directory and the engines folder inside parts will end up in parts / engines .
Image

kimkgb
Associate
Posts: 2
Joined: 17 Mar 2020 17:29

19 Mar 2020 15:23

Nightkid wrote:
19 Mar 2020 10:10
kimkgb wrote:
18 Mar 2020 17:26
Probably the best engine pack so far, love it!
But somehow i dont get the engine sound to work. :?

placed it in: Enginesounds-Engine-AddOns-

is this right? thanks for answer :D
ok here´s your answer
Copy Addon and parts folder into your main slrr directory . That way the addon folder will end up in the main slrr directory and the engines folder inside parts will end up in parts / engines .
Thanks for the help, did what u said and it works fine now :D

kscf31
Associate
Posts: 3
Joined: 11 Oct 2019 22:18

25 Mar 2020 00:02

I tried raising the rev limits on the parts I was using, and it won't start now. Yes, I know, I brought it on myself. However, I do this with every engine I use and have never had this issue. Any fixes?

User avatar
SimplifyHerb
Gangster
Posts: 395
Joined: 25 Sep 2019 10:48
Location: Osaka, Japan

25 Mar 2020 08:01

kscf31 wrote:
25 Mar 2020 00:02
I tried raising the rev limits on the parts I was using, and it won't start now. Yes, I know, I brought it on myself. However, I do this with every engine I use and have never had this issue. Any fixes?
He is completed awared problem, he was promised to fixed it when he got time.
Previous username; Buzzsaw.
My Roleplay Link: viewtopic.php?f=55&t=13457
RP location; Osaka, Japan

RP's My vehicle owned:
► Show Spoiler
RP's Angel's (My GF) vehicle owned:
► Show Spoiler
RP's My previous owned vehicle:
► Show Spoiler

kscf31
Associate
Posts: 3
Joined: 11 Oct 2019 22:18

26 Mar 2020 16:28

SimplifyHerb wrote:
25 Mar 2020 08:01
kscf31 wrote:
25 Mar 2020 00:02
I tried raising the rev limits on the parts I was using, and it won't start now. Yes, I know, I brought it on myself. However, I do this with every engine I use and have never had this issue. Any fixes?
He is completed awared problem, he was promised to fixed it when he got time.
Gotcha, sorry!!

User avatar
ijdevil
Associate
Posts: 42
Joined: 15 Jan 2020 13:41
Location: North Carolina

30 Mar 2020 15:26

kscf31 wrote:
25 Mar 2020 00:02
I tried raising the rev limits on the parts I was using, and it won't start now. Yes, I know, I brought it on myself. However, I do this with every engine I use and have never had this issue. Any fixes?
Increase the starter torque to like 40 or 50 then adjust from there.

kscf31
Associate
Posts: 3
Joined: 11 Oct 2019 22:18

30 Mar 2020 15:43

ijdevil wrote:
30 Mar 2020 15:26
kscf31 wrote:
25 Mar 2020 00:02
I tried raising the rev limits on the parts I was using, and it won't start now. Yes, I know, I brought it on myself. However, I do this with every engine I use and have never had this issue. Any fixes?
Increase the starter torque to like 40 or 50 then adjust from there.
Starter torque starts out at 80... I've adjusted it all over the place and it doesn't work. Even tried 8000 lol.

On one hand, yes I know I'm asking for problems by messing around with stuff. But at the same time, every other engine that has the javas included doesn't do this. So I'll just chill till he gets some time to look into it, no biggie! I did find that it gets REALLY mad when I change the efficiencies, which I find very strange. Again, something that doesn't happen on other engines.

Also, @Nightkid , any plans to do a nitrous rail for the Greddy manifold?

User avatar
Nightkid
Gangster
Posts: 218
Joined: 24 Sep 2019 13:43
Location: Saitama, Japan

30 Mar 2020 17:23

kscf31 wrote:
30 Mar 2020 15:43
ijdevil wrote:
30 Mar 2020 15:26
kscf31 wrote:
25 Mar 2020 00:02
I tried raising the rev limits on the parts I was using, and it won't start now. Yes, I know, I brought it on myself. However, I do this with every engine I use and have never had this issue. Any fixes?
Increase the starter torque to like 40 or 50 then adjust from there.
Starter torque starts out at 80... I've adjusted it all over the place and it doesn't work. Even tried 8000 lol.

On one hand, yes I know I'm asking for problems by messing around with stuff. But at the same time, every other engine that has the javas included doesn't do this. So I'll just chill till he gets some time to look into it, no biggie! I did find that it gets REALLY mad when I change the efficiencies, which I find very strange. Again, something that doesn't happen on other engines.

Also, @Nightkid , any plans to do a nitrous rail for the Greddy manifold?
lmao don’t ask me , i’m not the creator of the mod . I just did the screenshots xdd
Image

User avatar
SimplifyHerb
Gangster
Posts: 395
Joined: 25 Sep 2019 10:48
Location: Osaka, Japan

30 Mar 2020 17:26

kscf31 wrote:
30 Mar 2020 15:43
ijdevil wrote:
30 Mar 2020 15:26
kscf31 wrote:
25 Mar 2020 00:02
I tried raising the rev limits on the parts I was using, and it won't start now. Yes, I know, I brought it on myself. However, I do this with every engine I use and have never had this issue. Any fixes?
Increase the starter torque to like 40 or 50 then adjust from there.
Starter torque starts out at 80... I've adjusted it all over the place and it doesn't work. Even tried 8000 lol.

On one hand, yes I know I'm asking for problems by messing around with stuff. But at the same time, every other engine that has the javas included doesn't do this. So I'll just chill till he gets some time to look into it, no biggie! I did find that it gets REALLY mad when I change the efficiencies, which I find very strange. Again, something that doesn't happen on other engines.

Also, @Nightkid , any plans to do a nitrous rail for the Greddy manifold?
@Driftmonkey is owned it, not NightKid
Previous username; Buzzsaw.
My Roleplay Link: viewtopic.php?f=55&t=13457
RP location; Osaka, Japan

RP's My vehicle owned:
► Show Spoiler
RP's Angel's (My GF) vehicle owned:
► Show Spoiler
RP's My previous owned vehicle:
► Show Spoiler

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest